Картинка

БЛОГ про

все цікаве у світі телекомунікацій

Підключення до двох провайдерів з використанням IP SLA

2016-06-01
Автор: Телесфера

Часто постає задача налаштувати безперервну роботу офісної мережі. З цією метою підключаються два канали зв'язку, один з яких використовується, як резервний. Для налаштування працездатної схеми нам знадобиться маршрутизатор Cisco з підтримкою IP SLA та два канали Інтернет.  Плюс трохи ускладнимо завдання - частину трафіку потрібно буде примусово направити в резервний канал незалежно від працездатності. До того ж у нас буде локальний Веб сервер, який повинен бути доступний ззовні через два канали зв'язку.

Схема підключення 


Dual ISP SLA

Налаштування 

Налаштування інтерфейсів стандартні: GigabitEthernet0/0 дивиться в провайдера номер раз, GigabitEthernet0/1 в локалку, GigabitEthernet0/2 в провайдера номер два. 

interface GigabitEthernet0/0

description ISP_1

ip address 110.110.110.2 255.255.255.252

ip nat outside

 

interface GigabitEthernet0/1

description LAN

ip address 192.168.1.1 255.255.255.0

ip nat inside

!

interface GigabitEthernet0/2

description ISP_2

ip address 220.220.220.2 255.255.255.252

ip nat outside

!

Налаштуємо стеження за станом каналів 

ip sla 1

icmp-echo 110.110.110.1 source-interface GigabitEthernet0/0

threshold 2000

 timeout 2000

 frequency 10

!

ip sla 2

icmp-echo 220.220.220.1 source-interface GigabitEthernet0/2

threshold 2000

 timeout 2000

 frequency 10

!

ip sla group schedule 1 1-2 schedule-period 10 start-time now life forever

!

track 1 ip sla 1 reachability

track 2 ip sla 2 reachability

  

Тепер додаємо маршрутизацію, причому буде додатковий маршрут в локалку 2ого провайдера і в route-map буде відпрацьовуватися виключення цього напрямку з першого nat першого провайдера. 

ip route 0.0.0.0 0.0.0.0 110.110.110.1 10 track 1

ip route 0.0.0.0 0.0.0.0 220.220.220.1 20 track 2

ip route 172.18.48.0 255.255.255.0 220.220.220.1

!

ip access-list extended NAT

permit ip 192.168.1.0 0.0.0.255 any

!

ip access-list extended NET_172.16.31.0

permit ip any 172.16.31.0 0.0.0.255

!

route-map ISP1 deny 5

match ip address NET_172.16.31.0

!

route-map ISP1 permit 10

match ip address NAT

match interface GigabitEthernet0/0

!

route-map ISP2 permit 10

match ip address NAT

match interface GigabitEthernet0/2

 

Налаштуємо NAT 

ip nat inside source route-map ISP1 interface GigabitEthernet0/0 overload

ip nat inside source route-map ISP2 interface GigabitEthernet0/2 overload

 

У випадку коли потрібно прокинути порти для сервера, що знаходиться в нашій локалці налаштовуємо статичний NAT наступним чином.

Створюємо дві карти маршрутизації, для доступності сервісу на кожному з провайдерських лінків:

route-map ISP_1_STATIC permit 10

 match interface GigabitEthernet0/0

!

route-map ISP_2_STATIC permit 10

 match interface GigabitEthernet0/2

 

 Прописуємо правила трансляції

 

ip nat inside source static tcp 192.168.1.4 80 110.110.110.2 80 route-map ISP_1_STATIC extendable

ip nat inside source static tcp 192.168.1.4 80 220.220.220.1 80 route-map ISP_2_STATIC extendable

Перевірка роботи 


Стан роботи перевірки каналів можна дивитися командою sh ip sla statistics details 
Перевірка роботи NAT - команда show ip nat translations 


Про компанію Телесфера Інтеграція.

Телесфера Інтеграція заснована в 2012 році та являється інтегратором новітніх технологічних рішень для бізнесу.  Ми розробляємо рішення, що роблять Ваш бізнес успішним.

Основні напрямки роботи компанії:

  • Побудова локальних обчислювальних мереж;
  • Налаштування мережевого обладнання передових виробників (Cisco Systems, Aruba Networks та інших);
  • Продаж телекомунікаційного обладнання;
  • Аудит локальних обчислювальних мереж;

e-mail: office@telesphera.net
Телефон: (093) 198-11-82

КОММЕНТАРІ ДО СТАТТІ

Мікрофілія EdgeConnect від Aruba покликана спростити віддалену роботу в мережі

Мікрофілія EdgeConnect від Aruba покликана спростити віддалену роботу в мережі
Aruba Networks,Налаштування,Налаштування Aruba,новини,Продуктивність

Компанія Aruba Networks, дочірня компанія Hewlett Packard Enterprise (HPE), анонсувала нову пропозицію під назвою EdgeConnect Microbranch, призначену для спрощення складної мережевої роботи вдома для підприємств. COVID-19 змусив підприємства змінити спосіб використання своїх мереж, оскільки їм доводилося підтримувати зростання кількості користувачів та пристроїв, що підключаються з віддалених місць.

Тенденції ІБ: платформений підхід, аналітика та NaaS

Тенденції ІБ: платформений підхід, аналітика та NaaS
Cisco,cisco,cisco безпека,Налаштування Cisco,новини

Cisco розповіла, як захистити хмарних користувачів, чим корисний "інженерний хаос" і чого чекати від 2022 року. 20 грудня компанія Cisco організувала для журналістів онлайн-брифінг, присвячений підсумкам 2021 та перспективам 2022 року. Сisco регулярно проводить опитування замовників та на основі отриманих результатів готує аналітичні матеріали. Нещодавно компанія випустила два нові великі звіти: Security Outcomes Study Volume 2 і 2021 Global Networking Trends. У першому аналізується те, що відбувалося протягом 2021 року в області ІБ, другий описує глобальні тренди у мережах.

CISCO – Mikrotik — FLEXVPN

CISCO – Mikrotik — FLEXVPN
Cisco,Cisco Network,cisco,Блог Телесфера,Налаштування Cisco,Продуктивність

У даній документації розглядається приклад робочої конфігурації з'єднання роутера CISCO з роутером Mikrotik через тунель GRE з IPSec шифруванням в транспортному режимі. У побудові IPsec буде використовуватися IKEv2 та аутентифікація за PSK. Усередині тунелю буде піднято протокол динамічної маршрутизації OSPF для обміну маршрутами про мережі, що знаходяться за peer-ами.